summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 770e79d..6bd3356 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,10 +6,10 @@ if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
set(CMAKE_BUILD_PARALLEL_LEVEL 4 CACHE STRING "" FORCE)
endif()
-option(KIT_ENABLE_TESTING "Enable testing" ON)
-
-option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
-option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
+option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
+option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
+option(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH "Enable custom allocator dispatch" OFF)
+option(KIT_ENABLE_TESTING "Enable testing" ON)
project(
kit
@@ -114,6 +114,10 @@ if(KIT_DISABLE_SYSTEM_THREADS)
target_compile_definitions(kit PUBLIC KIT_DISABLE_SYSTEM_THREADS)
endif()
+if(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
+ target_compile_definitions(kit PUBLIC KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
+endif()
+
if(NOT KIT_DISABLE_SYSTEM_THREADS)
find_package(Threads REQUIRED)
target_link_libraries(kit PUBLIC Threads::Threads)