summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <automainint@guattari.tech>2023-03-24 22:51:12 +0100
committerMitya Selivanov <automainint@guattari.tech>2023-03-24 22:51:12 +0100
commitb6179af210b0ed92224506dce0978c20d8d6fba7 (patch)
tree8368f703914c83490be519099a03c1274f1034be /CMakeLists.txt
parente071aa5408ca617172923214aaf61b4cd3733483 (diff)
downloadkit-b6179af210b0ed92224506dce0978c20d8d6fba7.zip
Custom alloc dispatch mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 770e79d..6bd3356 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,10 +6,10 @@ if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
set(CMAKE_BUILD_PARALLEL_LEVEL 4 CACHE STRING "" FORCE)
endif()
-option(KIT_ENABLE_TESTING "Enable testing" ON)
-
-option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
-option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
+option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
+option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
+option(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH "Enable custom allocator dispatch" OFF)
+option(KIT_ENABLE_TESTING "Enable testing" ON)
project(
kit
@@ -114,6 +114,10 @@ if(KIT_DISABLE_SYSTEM_THREADS)
target_compile_definitions(kit PUBLIC KIT_DISABLE_SYSTEM_THREADS)
endif()
+if(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
+ target_compile_definitions(kit PUBLIC KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
+endif()
+
if(NOT KIT_DISABLE_SYSTEM_THREADS)
find_package(Threads REQUIRED)
target_link_libraries(kit PUBLIC Threads::Threads)