summaryrefslogtreecommitdiff
path: root/source/kit_test/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <0x7fffff@guattari.ru>2022-08-05 21:17:16 +0400
committerMitya Selivanov <0x7fffff@guattari.ru>2022-08-05 21:17:16 +0400
commit26dfa76faa883c35fe3e5ff4b2b33f4102059a81 (patch)
tree27b71a44b38fb4b64e991146e235ae327c86ef5d /source/kit_test/CMakeLists.txt
downloadkit-26dfa76faa883c35fe3e5ff4b2b33f4102059a81.zip
Async function & unit-testing
Diffstat (limited to 'source/kit_test/CMakeLists.txt')
-rw-r--r--source/kit_test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/source/kit_test/CMakeLists.txt b/source/kit_test/CMakeLists.txt
new file mode 100644
index 0000000..f7315a1
--- /dev/null
+++ b/source/kit_test/CMakeLists.txt
@@ -0,0 +1,6 @@
+target_sources(
+ ${KIT_TEST_LIBRARY}
+ PRIVATE
+ run_tests.c
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/test.h>)