summaryrefslogtreecommitdiff
path: root/source/test/programs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/test/programs/CMakeLists.txt')
-rw-r--r--source/test/programs/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/source/test/programs/CMakeLists.txt b/source/test/programs/CMakeLists.txt
index 4fd3660..641aa16 100644
--- a/source/test/programs/CMakeLists.txt
+++ b/source/test/programs/CMakeLists.txt
@@ -18,4 +18,14 @@ if(KIT_ENABLE_TESTING)
too_many_assertions_test
PROPERTIES
TIMEOUT "30")
+
+ add_executable(cpp cpp.cpp)
+ target_link_libraries(cpp ${KIT_TEST_LIBRARY})
+ add_test(
+ NAME cpp_test
+ COMMAND cpp)
+ set_tests_properties(
+ cpp_test
+ PROPERTIES
+ TIMEOUT "30")
endif()