summaryrefslogtreecommitdiff
path: root/source/test/integration/find_package/source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/test/integration/find_package/source/CMakeLists.txt')
-rw-r--r--source/test/integration/find_package/source/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/source/test/integration/find_package/source/CMakeLists.txt b/source/test/integration/find_package/source/CMakeLists.txt
new file mode 100644
index 0000000..2dc34a1
--- /dev/null
+++ b/source/test/integration/find_package/source/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 3.16)
+set(NAME kit-integration-find-package)
+project(${NAME} C)
+
+find_package(kit REQUIRED)
+
+add_executable(${NAME})
+target_sources(${NAME} PRIVATE main.c)
+target_link_libraries(${NAME} PRIVATE kit::kit)
+install(TARGETS ${NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})