summaryrefslogtreecommitdiff
path: root/source/test/integration/find_package/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/test/integration/find_package/CMakeLists.txt')
-rw-r--r--source/test/integration/find_package/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/source/test/integration/find_package/CMakeLists.txt b/source/test/integration/find_package/CMakeLists.txt
deleted file mode 100644
index f21cdae..0000000
--- a/source/test/integration/find_package/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-cmake_minimum_required(VERSION 3.16)
-set(NAME kit-integration-find-package)
-project(${NAME}-root)
-
-include(ExternalProject)
-
-ExternalProject_Add(
- kit
- GIT_REPOSITORY https://github.com/automainint/kit.git
- GIT_TAG dev
- CMAKE_ARGS
- -D CMAKE_INSTALL_PREFIX=${CMAKE_CURRENT_SOURCE_DIR}/install
- -D KIT_ENABLE_TESTING=OFF)
-
-ExternalProject_Add(
- ${NAME}
- SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/source
- CMAKE_ARGS
- -D CMAKE_INSTALL_PREFIX=${CMAKE_CURRENT_SOURCE_DIR}/install)
-
-ExternalProject_Add_StepDependencies(${NAME} build kit)
-
-include(GNUInstallDirs)
-
-enable_testing()
-
-add_test(
- NAME ${NAME}-run
- COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/install/${CMAKE_INSTALL_BINDIR}/${NAME}${CMAKE_EXECUTABLE_SUFFIX})
-
-set_tests_properties(
- ${NAME}-run
- PROPERTIES
- TIMEOUT "15")