summaryrefslogtreecommitdiff
path: root/source/test/integration/fetch_content/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/test/integration/fetch_content/CMakeLists.txt')
-rw-r--r--source/test/integration/fetch_content/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/source/test/integration/fetch_content/CMakeLists.txt b/source/test/integration/fetch_content/CMakeLists.txt
deleted file mode 100644
index efa83d0..0000000
--- a/source/test/integration/fetch_content/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-cmake_minimum_required(VERSION 3.16)
-set(NAME kit-integration-fetch-content)
-project(${NAME} C)
-
-include(FetchContent)
-FetchContent_Declare(
- kit
- GIT_REPOSITORY https://github.com/automainint/kit.git
- GIT_TAG dev)
-set(KIT_ENABLE_TESTING OFF)
-FetchContent_MakeAvailable(kit)
-
-add_executable(${NAME})
-target_sources(${NAME} PRIVATE main.c)
-target_link_libraries(${NAME} PRIVATE kit::kit)
-
-enable_testing()
-add_test(NAME ${NAME}-run COMMAND ${NAME})
-set_tests_properties(${NAME}-run PROPERTIES TIMEOUT "15")