summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index e776a29..a0206b3 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -1,11 +1,9 @@
target_sources(
kit
PRIVATE
- input_buffer.c bigint.c status.c secure_random.c
- sha256.c thread.posix.c atomic.win32.c condition_variable.c
- thread.win32.c move_back.c input_stream.c file.c string_ref.c
- async_function.c allocator.c array_ref.c dynamic_array.c mutex.c
- mersenne_twister_64.c
+ input_buffer.c secure_random.c sha256.c thread.posix.c
+ atomic.win32.c condition_variable.c thread.win32.c input_stream.c file.c
+ allocator.c array_ref.c dynamic_array.c mutex.c mersenne_twister_64.c
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mutex.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/status.h>