summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07b2738..6dacbc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,11 +7,12 @@ if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
endif()
option(KIT_ENABLE_TESTING "Enable testing" ON)
+option(KIT_FORCE_ANSI_C "Force ANSI C" ${KIT_ENABLE_TESTING})
option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
-if(KIT_ENABLE_TESTING)
+if(KIT_FORCE_ANSI_C)
set(CMAKE_C_STANDARD 90)
set(CMAKE_C_EXTENSIONS OFF)
endif()