summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <automainint@guattari.tech>2023-04-08 01:41:32 +0200
committerMitya Selivanov <automainint@guattari.tech>2023-04-08 01:41:32 +0200
commitfa8d01934681195aacea8b95c78f27ca6a660bdd (patch)
tree98c5efa3b6b0cb9a877f244df441f012ff0fbee0 /CMakeLists.txt
parent4d720c77b3a91d517552e8b991577936f172a5cb (diff)
downloadkit-fa8d01934681195aacea8b95c78f27ca6a660bdd.zip
Simplify async function
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bd3356..b199e4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,10 +6,11 @@ if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
set(CMAKE_BUILD_PARALLEL_LEVEL 4 CACHE STRING "" FORCE)
endif()
-option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
-option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
-option(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH "Enable custom allocator dispatch" OFF)
-option(KIT_ENABLE_TESTING "Enable testing" ON)
+option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
+option(KIT_DISABLE_SYSTEM_THREADS "Disable system threads" OFF)
+option(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH "Enable custom allocator dispatch" OFF)
+option(KIT_ENABLE_CUSTOM_ASYNC_FUNCTION_DISPATCH "Enable custom async function dispatch" OFF)
+option(KIT_ENABLE_TESTING "Enable testing" ON)
project(
kit
@@ -118,6 +119,10 @@ if(KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
target_compile_definitions(kit PUBLIC KIT_ENABLE_CUSTOM_ALLOC_DISPATCH)
endif()
+if(KIT_ENABLE_CUSTOM_ASYNC_FUNCTION_DISPATCH)
+ target_compile_definitions(kit PUBLIC KIT_ENABLE_CUSTOM_ASYNC_FUNCTION_DISPATCH)
+endif()
+
if(NOT KIT_DISABLE_SYSTEM_THREADS)
find_package(Threads REQUIRED)
target_link_libraries(kit PUBLIC Threads::Threads)