summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <automainint@guattari.tech>2022-11-23 21:39:31 +0100
committerMitya Selivanov <automainint@guattari.tech>2022-11-23 21:39:31 +0100
commite6e08719392318a643dc2d8243fdf84e6534c647 (patch)
tree029ba8c5ccf0288ff0fa4980a2c5b275d61c225a /CMakeLists.txt
parentfda748ade9285c61cc681f700d0536ca0cf8b0d5 (diff)
downloadkit-e6e08719392318a643dc2d8243fdf84e6534c647.zip
Remove codecov
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b0719e..b5d1cc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,11 @@
cmake_minimum_required(VERSION 3.16)
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON CACHE BOOL "" FORCE)
+
+if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
+ set(CMAKE_BUILD_PARALLEL_LEVEL 4 CACHE STRING "" FORCE)
+endif()
+
option(KIT_ENABLE_TESTING "Enable testing" ON)
option(KIT_DISABLE_SYSTEM_MALLOC "Disable system memory allocator" OFF)
@@ -11,10 +17,6 @@ set(KIT_TEST_LIBRARY kit_test)
set(KIT_TEST_SUITE kit_test_suite)
set(KIT_TARGETS kit-targets)
-if(NOT DEFINED CMAKE_BUILD_PARALLEL_LEVEL)
- set(CMAKE_BUILD_PARALLEL_LEVEL 4)
-endif()
-
project(
${KIT_PROJECT}
VERSION 0.1.1
@@ -211,4 +213,4 @@ install(
"${CMAKE_CURRENT_BINARY_DIR}/${project_lower_}-config-version.cmake"
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME})
-unset(project_lower_) \ No newline at end of file
+unset(project_lower_)