summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <0x7fffff@guattari.ru>2022-08-14 05:51:15 +0400
committerMitya Selivanov <0x7fffff@guattari.ru>2022-08-14 05:51:15 +0400
commit9d52013ba61944ae437078c163e05d504ae989dc (patch)
treee790fde21e1c11b84be26bf982ead4b8e780739b /CMakeLists.txt
parent017e851436459cd80f15cd1071a2b02758a7c61f (diff)
downloadkit-9d52013ba61944ae437078c163e05d504ae989dc.zip
[CMake] Check for C compiler instead of CXX
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6903439..f00e62e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ if(KIT_ENABLE_TESTING)
target_compile_features(${KIT_TEST_SUITE} PRIVATE c_std_11)
target_link_libraries(${KIT_TEST_SUITE} PRIVATE ${KIT_LIBRARY} ${KIT_TEST_LIBRARY} Threads::Threads)
- if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+ if(CMAKE_C_COMPILER_ID MATCHES "GNU|Clang")
target_compile_options(
${KIT_LIBRARY} PUBLIC
-fsanitize=undefined,address