summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <0x7fffff@guattari.ru>2022-08-09 22:28:14 +0400
committerMitya Selivanov <0x7fffff@guattari.ru>2022-08-09 22:28:14 +0400
commit0b1c0f3eb647a7630b473bfec75a3411dab89583 (patch)
tree7653b70708b1dbc705e52a9609e0f851ba2ce00b /CMakeLists.txt
parent2adba315f23733634ca01e1aa53ca5dcdbf43d30 (diff)
downloadkit-0b1c0f3eb647a7630b473bfec75a3411dab89583.zip
[CMake] Compile features
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8496ab4..8ec04fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ if(KIT_ENABLE_LIBRARY OR KIT_ENABLE_TESTING)
${KIT_TEST_LIBRARY} INTERFACE
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/source>)
target_compile_features(${KIT_TEST_LIBRARY} PUBLIC c_std_11)
+ target_compile_features(${KIT_TEST_LIBRARY} PUBLIC cxx_std_11)
endif()
enable_testing()