summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMitya Selivanov <0x7fffff@guattari.ru>2022-08-18 16:41:40 +0400
committerMitya Selivanov <0x7fffff@guattari.ru>2022-08-18 16:41:40 +0400
commit06a85c253005a0b95976dbecae8286a5f6603ba3 (patch)
tree2ee2913311d443faa2e5c43bec669b7f9c902835 /CMakeLists.txt
parent89686cc730c61227b9874fb4be37c52108ac2c08 (diff)
downloadkit-06a85c253005a0b95976dbecae8286a5f6603ba3.zip
Refactor
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b96abd8..b8b5d20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,14 +101,6 @@ if(KIT_HAVE_TIMESPEC_GET)
target_compile_definitions(${KIT_LIBRARY} PUBLIC KIT_HAVE_TIMESPEC_GET)
endif()
-if(KIT_HAVE_PTHREAD)
- target_compile_definitions(${KIT_LIBRARY} PUBLIC KIT_HAVE_PTHREAD)
-endif()
-
-if(KIT_HAVE_WINDOWS)
- target_compile_definitions(${KIT_LIBRARY} PUBLIC KIT_HAVE_WINDOWS)
-endif()
-
if(KIT_DISABLE_SYSTEM_MALLOC)
target_compile_definitions(${KIT_LIBRARY} PUBLIC KIT_DISABLE_SYSTEM_MALLOC)
endif()