summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index b5fe0f6..a8aaf02 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -2,7 +2,7 @@ target_sources(
${KIT_LIBRARY}
PRIVATE
atomic.c input_buffer.c threads.win32.c time.c
- threads.posix.c input_stream.c lower_bound.c string_ref.c
+ threads.posix.c move_back.c input_stream.c lower_bound.c string_ref.c
async_function.c allocator.c array_ref.c dynamic_array.c
mersenne_twister_64.c
PUBLIC
@@ -13,6 +13,7 @@ target_sources(
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/threads.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/dynamic_array.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/async_function.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/move_back.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_stream.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_buffer.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/lower_bound.h>