summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index 4113668..e776a29 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -2,9 +2,10 @@ target_sources(
kit
PRIVATE
input_buffer.c bigint.c status.c secure_random.c
- thread.posix.c atomic.win32.c condition_variable.c thread.win32.c
- move_back.c input_stream.c file.c string_ref.c async_function.c
- allocator.c array_ref.c dynamic_array.c mutex.c mersenne_twister_64.c
+ sha256.c thread.posix.c atomic.win32.c condition_variable.c
+ thread.win32.c move_back.c input_stream.c file.c string_ref.c
+ async_function.c allocator.c array_ref.c dynamic_array.c mutex.c
+ mersenne_twister_64.c
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mutex.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/status.h>
@@ -22,6 +23,7 @@ target_sources(
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/thread_defs.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_buffer.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/lower_bound.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/sha256.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/file.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/array_ref.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mersenne_twister_64.h>)