summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index f9a30d2..e12077a 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -1,8 +1,8 @@
target_sources(
${KIT_LIBRARY}
PRIVATE
- input_buffer.c bigint.c status.c threads.win32.c time.c
- secure_random.c atomic.win32.c threads.posix.c condition_variable.c
+ input_buffer.c bigint.c status.c time.c secure_random.c
+ thread.posix.c atomic.win32.c condition_variable.c thread.win32.c
move_back.c input_stream.c lower_bound.c file.c string_ref.c
async_function.c allocator.c array_ref.c dynamic_array.c mutex.c
mersenne_twister_64.c
@@ -13,7 +13,7 @@ target_sources(
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/atomic.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/allocator.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/string_ref.h>
- $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/threads.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/thread.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/bigint.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/dynamic_array.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/condition_variable.h>