summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index 5954992..f9a30d2 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -2,9 +2,10 @@ target_sources(
${KIT_LIBRARY}
PRIVATE
input_buffer.c bigint.c status.c threads.win32.c time.c
- atomic.win32.c threads.posix.c condition_variable.c move_back.c
- input_stream.c lower_bound.c file.c string_ref.c async_function.c
- allocator.c array_ref.c dynamic_array.c mutex.c mersenne_twister_64.c
+ secure_random.c atomic.win32.c threads.posix.c condition_variable.c
+ move_back.c input_stream.c lower_bound.c file.c string_ref.c
+ async_function.c allocator.c array_ref.c dynamic_array.c mutex.c
+ mersenne_twister_64.c
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mutex.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/status.h>
@@ -18,6 +19,7 @@ target_sources(
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/condition_variable.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/async_function.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/move_back.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/secure_random.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_stream.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_buffer.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/lower_bound.h>