summaryrefslogtreecommitdiff
path: root/source/kit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/kit/CMakeLists.txt')
-rw-r--r--source/kit/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/kit/CMakeLists.txt b/source/kit/CMakeLists.txt
index 7bc3ba5..1dbaaf8 100644
--- a/source/kit/CMakeLists.txt
+++ b/source/kit/CMakeLists.txt
@@ -3,8 +3,8 @@ target_sources(
PRIVATE
input_buffer.c threads.win32.c time.c atomic.win32.c
threads.posix.c condition_variable.c move_back.c input_stream.c
- lower_bound.c string_ref.c async_function.c allocator.c array_ref.c
- dynamic_array.c mutex.c mersenne_twister_64.c
+ lower_bound.c file.c string_ref.c async_function.c allocator.c
+ array_ref.c dynamic_array.c mutex.c mersenne_twister_64.c
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mutex.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/time.h>
@@ -19,5 +19,7 @@ target_sources(
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_stream.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/input_buffer.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/lower_bound.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/file.h>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/options.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/array_ref.h>
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/mersenne_twister_64.h>)